• 欢迎加入EmulatedLab主群:593920308,EmulatedLab②群:178989902!
  • 如果您喜欢本站,那么赶紧按Ctrl+D收藏EmulatedLab吧!

GNS3上实现IPv6与IPv4的NAT-PT

GNS3 Maosen | 森 3年前 (2017-07-26) 4591次浏览 1个评论 扫描二维码
文章目录[隐藏]

静态NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

PCv4设备配置

PCv4(config)#int f0/0

PCv4(config-if)#ip add 192.168.1.2 255.255.255.0

PCv4(config-if)#no shutdown

PCv4(config-if)#exit

PCv4(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.1

PCv4(config)#

 

PCv6设备配置

PCv6(config)#int f0/0

PCv6(config-if)#ipv6 address 2001:1::2/64

PCv6(config-if)#no shutdown

PCv6(config-if)#exit

PCv6(config)#ipv6 route ::/0 f0/0 2001:1::1

PCv6(config)#end

 

NAT-PT设备配置

NAT-PT(config)#int f0/0

NAT-PT(config-if)#ip add 192.168.1.1 255.255.255.0

NAT-PT(config-if)#ipv6 nat    //启用NAT-PT

NAT-PT(config-if)#no shutdown

NAT-PT(config-if)#exit

NAT-PT(config)#int f0/1

NAT-PT(config-if)#ipv6 address 2001:1::1/64

NAT-PT(config-if)#no shutdown

NAT-PT(config-if)#ipv6 nat

NAT-PT(config-if)#exit

NAT-PT(config)#ipv6 nat v4v6 source 192.168.1.2 2001:2::2 //配置v4转换到v6

NAT-PT(config)#ipv6 nat v6v4 source 2001:1::2 192.168.2.2 //配置v6转换到v4

NAT-PT(config)#ipv6 nat prefix 2001:2::/96 //配置符合此地址段的报文进行NAT-PT转换

NAT-PT(config)#

NAT-PT(config)#no ip cef //必须敲,缺失则导致实验失败

各设备show结果

PCv4#sh run int f0/0

Building configuration…

 

Current configuration : 96 bytes

!

interface FastEthernet0/0

ip address 192.168.1.2 255.255.255.0

duplex auto

speed auto

end

 

PCv4#sh ip route

Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route

 

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

 

C    192.168.1.0/24 is directly connected, FastEthernet0/0

S*   0.0.0.0/0 [1/0] via 192.168.1.1

PCv4#

 

PCv6#sh run int f0/0

Building configuration…

 

Current configuration : 100 bytes

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2001:1::2/64

end

 

PCv6#sh ipv

PCv6#sh ipv6 route

IPv6 Routing Table – 5 entries

Codes: C – Connected, L – Local, S – Static, R – RIP, B – BGP

U – Per-user Static route

I1 – ISIS L1, I2 – ISIS L2, IA – ISIS interarea, IS – ISIS summary

O – OSPF intra, OI – OSPF inter, OE1 – OSPF ext 1, OE2 – OSPF ext 2

ON1 – OSPF NSSA ext 1, ON2 – OSPF NSSA ext 2

D – EIGRP, EX – EIGRP external

S   ::/0 [1/0]

via 2001:1::1, FastEthernet0/0

C   2001:1::/64 [0/0]

via ::, FastEthernet0/0

L   2001:1::2/128 [0/0]

via ::, FastEthernet0/0

L   FE80::/10 [0/0]

via ::, Null0

L   FF00::/8 [0/0]

via ::, Null0

PCv6#

 

NAT-PT#sh run int f0/0

Building configuration…

 

Current configuration : 106 bytes

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

ipv6 nat

end

 

NAT-PT#sh run int f0/1

Building configuration…

 

Current configuration : 110 bytes

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

ipv6 address 2001:1::1/64

ipv6 nat

end

 

NAT-PT#sh run | se ipv6 nat

ipv6 nat

ipv6 nat

ipv6 nat v4v6 source 192.168.1.2 2001:2::2

ipv6 nat v6v4 source 2001:1::2 192.168.2.2

ipv6 nat prefix 2001:2::/96

NAT-PT#

 

注意:NAT-PT设备必须要关闭CEF,否则会出现数据报一半通一半不通情况

GNS3上实现IPv6与IPv4的NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

正常检测结果

GNS3上实现IPv6与IPv4的NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

PCv4 ping 192.168.2.2时,NAT-PT的debug结果

GNS3上实现IPv6与IPv4的NAT-PT

PCv6 ping 2001:2::2时,NAT-PT设备debug结果

GNS3上实现IPv6与IPv4的NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

 

动态NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

PCv4与PCv6配置与静态相同

NAT-PT设备配置

接口地址也与静态NAT-PT配置相同

NAT-PT(config)#ipv6 access-list v6v4

NAT-PT(config-ipv6-acl)#permit ipv6 2001:1::/64 any

NAT-PT(config-ipv6-acl)#exit

NAT-PT(config)# ipv6 nat v6v4 pool POOL 192.168.2.2 192.168.2.10 prefix-length 24 //配置动态映射v6到v4所用地址池

NAT-PT(config)#ipv6 nat v6v4 source list v6v4 pool POOL  //配置v6动态映射到v4时调用pool地址池

NAT-PT(config)#ipv6 nat v4v6 source 192.168.1.2 2002::2  //配置v4静态映射到v6地址

NAT-PT(config)#ipv6 nat prefix 2002::/96              //配置2002::/96地址时用NAT-PT

NAT-PT(config)#end

NAT-PT#

 

注意:动态NAT-PT中指的是v6—->v4时是动态,而v4—->v6时是静态

实验结果:

在测试时首先要PCv6 ping 2002::2(PCv4)

GNS3上实现IPv6与IPv4的NAT-PT

而PCv4 ping PCv6的时候,一定要在NAT-PT上查看映射地址,ping映射后的地址才可以保证ping通

GNS3上实现IPv6与IPv4的NAT-PT

此时映射的是192.168.2.2

所以在PCv4上ping 192.168.2.2,就能保证ping通PCv6

GNS3上实现IPv6与IPv4的NAT-PT

查看地址转换情况

GNS3上实现IPv6与IPv4的NAT-PT

debug ipv6 nat结果:

GNS3上实现IPv6与IPv4的NAT-PT

 

动态PAT-PT端口映射(类似于IPv4中的PAT)

PCv4与PCv6配置与静态相同

NAT-PT设备配置

接口地址也与静态NAT-PT配置相同

NAT-PT(config)#ipv6 access-list v6v4

NAT-PT(config-ipv6-acl)#permit ipv6 2001:1::/64 any

NAT-PT(config-ipv6-acl)#exit

NAT-PT(config)# ipv6 nat v6v4 pool POOL 192.168.2.2 192.168.2.10 prefix-length 24 //配置动态映射v6到v4所用地址池

NAT-PT(config)#ipv6 nat v6v4 source list v6v4 pool POOL overload//只有此处与动态NAT-PT不一样,其他地方均相同

NAT-PT(config)#ipv6 nat v4v6 source 192.168.1.2 2002::2  //配置v4静态映射到v6地址

NAT-PT(config)#ipv6 nat prefix 2002::/96              //配置2002::/96地址时用NAT-PT

NAT-PT(config)#end

NAT-PT#

注意:动态NAT-PT中指的是v6—->v4时是动态,而v4—->v6时是静态

实验结果:

GNS3上实现IPv6与IPv4的NAT-PT

GNS3上实现IPv6与IPv4的NAT-PT

此处不通是因为PCv4上没有开启telnet,只是为了查看地址转换结果

GNS3上实现IPv6与IPv4的NAT-PT

此时PCv4是ping不通PCv6的,因为映射是属于端口映射,而ICMP协议的映射是通过ICMP报文的某一字段来标识的,所以此时无论如何都ping不通,但上层TCP UDP协议可以通过端口运行,但每一次映射的端口号是随机的,所以想要PCv4与PCv6通信,还是比较有难度的,如下图所示

GNS3上实现IPv6与IPv4的NAT-PT

Debug 结果:

GNS3上实现IPv6与IPv4的NAT-PT

其他NAT-PT特性

更改动态转换的超时时间,默认为86400s,也可以针对协议单独调整

GNS3上实现IPv6与IPv4的NAT-PT

更改NAT-PT同时处理的转换条目,默认是不限制

GNS3上实现IPv6与IPv4的NAT-PT

 

该篇也曾是我上学时做的一部分作业,优秀成绩,献丑了!


如未注明,均为原创,版权归EmulatedLab所有!转载请注明出处,否则追究法律责任!
喜欢 (10)
[sms1107]
分享 (0)
Maosen | 森
关于作者:
真正的强者从不畏惧别人比你更强!

您必须 登录 才能发表评论!

(1)个小伙伴在吐槽
  1. 请问下你GNS3使用的是那个镜像?
    hilivivi2018-05-06 20:39